Archives
Trending
Support
Login
clear text
XML
Django
JavaScript
MATLAB
C
C++
C#
Python
SQL
Shell
Bash
Markdown
YAML
JSON
HTML
CSS
PHP
Java
Ruby
Go
Rust
Swift
Kotlin
Arduino
TypeScript
Perl
Autohotkey
Lua
SQF
R
Scala
Haskell
Groovy
Dart
Clojure
VB.NET
Objective-C
PowerShell
Bash
CoffeeScript
Verilog
let WindowsPatchVulns = DeviceTvmSoftwareVulnerabilities | where OSPlatform startswith "Windows" | where isnotempty(RecommendedSecurityUpdateId) | join kind=leftouter ( DeviceTvmSoftwareVulnerabilitiesKB | project CveId, PublishedDate, IsExploitAvailable, CvssScore ) on CveId | extend PatchAgeDays = datetime_diff("day", now(), PublishedDate); WindowsPatchVulns | summarize OldestMissingPatchDays = max(PatchAgeDays), OldestVulnPublished = min(PublishedDate), MissingKBs = make_set(RecommendedSecurityUpdateId, 20), MissingUpdateNames = make_set(RecommendedSecurityUpdate, 20), CriticalCount = countif(VulnerabilitySeverityLevel == "Critical"), HighCount = countif(VulnerabilitySeverityLevel == "High"), ExploitableCount = countif(IsExploitAvailable == true), TotalVulns = dcount(CveId) by DeviceName, DeviceId, OSPlatform, OSVersion | extend PatchBucket = case( OldestMissingPatchDays <= 30, "0-30 days", OldestMissingPatchDays <= 60, "31-60 days", OldestMissingPatchDays <= 90, "61-90 days", OldestMissingPatchDays <= 180, "91-180 days", "180+ days" ) | order by OldestMissingPatchDays desc
Mark as private (unlisted)
for 30 minutes
for 6 hours
for 1 day
for 1 week
for 1 month
for 1 year
everlasting (like CCCP)